Results 1 to 7 of 7

Thread: cups networking problem

  1. #1
    Newbie
    Join Date
    Oct 2004
    Posts
    3

    cups networking problem

    Hi,

    I hope somebody can help. I've posted this to linuxquesitons and justlinux, and gotten no replies.

    I'm trying to do something I had hoped would be really simple. I've got a home network of only linux machines. My server is fedora core 2, and I have a samsung ml-4500 laser printer connected via the local parallel port. I'm using cups, and the printer works fine locally. My other computers are networked via ethernet. I'm running the shorewall firewall on the server, but brought it down because I thought it might be causing problems. I get the same problem whether the firewall is running or not. No firewall on the other computers either, for testing purposes. I use the system-config-printer utility in fedora on the server machine. It shows the printer connected locally on /dev/lp0. I configured the ML-4500 printer driver. Under 'sharing' I've checked 'This queue is available to other computers', and 'allowed hosts' I have as 'Network device eth1'. I also tried using my home network address range 192.168.0.0 with netmask 255.255.255.0, but get the same results.

    On the client machines, I have redhat 9.0 or fedora core 2. It doesn't matter which client machines I try, the result is the same. On a redhat 9.0 machine, I use the 'redhat-config-printer' utility, and under 'queue type' check 'Networked CUPS (IPP)', then select the samsung ml-4500 printer driver. When I try to print a test page from the client, whether from the config utility or from http://localhost:631, I get 'Printer busy; will retry in 10 seconds ...'.

    Here is my cupsd.conf on my server machine:
    # Lines below are automatically generated - DO NOT EDIT
    <Location /printers/SamsungML4500>
    Order Deny,Allow
    Deny From All
    Allow From 127.0.0.1
    AuthType None
    Allow from 192.168.0.0/255.255.255.0
    </Location>
    <Location />
    Order Deny,Allow
    Deny From All
    Allow From 127.0.0.1
    </Location>
    Browsing On
    BrowseProtocols cups
    BrowseOrder Deny,Allow
    BrowseAllow from @LOCAL
    BrowseAddress 192.168.0.255
    Listen 192.168.0.1:631
    Listen 127.0.0.1:631

    When I do netstat -ln -A inet, I get:
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State
    tcp 0 0 127.0.0.1:32768 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
    tcp 0 0 192.168.0.1:631 0.0.0.0:* LISTEN
    udp 0 0 0.0.0.0:111 0.0.0.0:*
    udp 0 0 0.0.0.0:631 0.0.0.0:*

    I'm sure that my main problem is that I don't understand linux networking well at all. Its all quite vague still.

    From a client, if I do telnet 192.168.0.1 631 I get:
    >Connected to 192.168.0.1 ...
    Escape character is '^['.

    So I guess the server port 631 is listening ok, but I don't really understand the port configuration for cups to work right.

    Using nmap from client machine, I see that the tcp port 631 is open on the server, but the udp port 631 is closed. I've tried to open it by adding relevent lines in my shorewall rule script, and by using the iptables command directly, all to no effect.

    Can anyone help me figure out where the problem is? Let me know what other data or info would be helpful.

  2. #2

    Re:cups networking problem

    [quote author=wilcsnyder link=board=4;threadid=9845;start=#msg89317 date=1097036759]
    When I try to print a test page from the client, whether from the config utility or from http://localhost:631, I get 'Printer busy; will retry in 10 seconds ...'.
    [/quote]

    I have never messed with printing let alone network printing in Linux but wouldn't the http://localhost:631 need to be http://192.168.0.1:631

  3. #3

    Re:cups networking problem

    hello,
    For some reason with FC2 I needed to flush my IPTABLES before I got it to work - seems like I had a thread here about it...

    here it is:
    http://www.linuxjunior.org/yabbse/in...;threadid=9277

  4. #4
    Newbie
    Join Date
    Oct 2004
    Posts
    3

    Re:cups networking problem

    Thanks for the replies so far!

    I looked through the other thread posted earlier by pbharris, it sounds like the exact same problem I'm having. But I stopped iptables, and still have the same problem from the other computers on the network, ''printer busy...". On one of the client computers on my network I fired up a browser and tried to go to http://192.168.0.1:631, and get a "Forbidden" message, whether my firewall is up or not.

    What does that mean? How can I allow access for the client computers on my server's cups? I thought I had done that when I made it a shared printer!

    Does anyone have any idea what might be going on? I'm kind of out to sea here on this one.

  5. #5
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:cups networking problem

    [quote author=wilcsnyder link=board=4;threadid=9845;start=0#msg89344 date=1097121212]
    But I stopped iptables, and still have the same problem from the other computers on the network[/quote]
    I think what they are saying is you just don't STOP the rules but you need to flash the rules sets. Issue command "iptables -F" as root from a termal and try again to make sure.

    I'm kind of out to sea here on this one.
    I'm not an cups expert so I dont' know. My only other suggestion is to go through again and see if you missed anything.

    I would start setting up all over again if I were you.

  6. #6

    Re:cups networking problem

    What he said.

    Also, I'd say that, in order to allow other pc's to access your cups web interface, you might need to edit the cups.conf file, to run as the hostname of the machine instead of 127.0.0.1.

    Afterwards, restart the daemon.

  7. #7
    Newbie
    Join Date
    Oct 2004
    Posts
    3

    Re:cups networking problem

    Thanks again for the replies. Tried everything, nothing works. I guess at this point I'll give up on cups networking and just use samba.

    Wil Snyder

Similar Threads

  1. networking problem between windos xp and linux
    By mwalam in forum Windows - General Topics
    Replies: 2
    Last Post: 08-30-2005, 07:58 PM
  2. Home networking problem
    By roneill in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 04-11-2005, 07:03 PM
  3. cups problem
    By Bogler in forum Redhat / Fedora
    Replies: 12
    Last Post: 03-12-2002, 10:39 PM
  4. CUPS - help
    By binary_boy in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 01-03-2002, 11:32 AM
  5. CUPS vs lpr
    By in forum Linux - General Topics
    Replies: 1
    Last Post: 12-16-2001, 05:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •