Well, i wasn't really sure where to put this, so I'm putting it here. I have spent the better part of half a day trying to get my nvidia drivers working. I'm running slack 10, with 2.6.7 and was trying to install the Nvidia 5336 drivers. With no luck, no matter what I did in the kernel I was unable to do it.
So I finally decided to download the new drivers, and in the changelog, I see they've added support for 4kb stack kernels. This I believe would be my problem, as it was something I just never assumed to change that. So if you've struggled with older nvidia drivers and 2.6 kernel, check if you're using 4kb stacks, if you are, get the latest drivers.
HTH someone out there
CP