Results 1 to 3 of 3

Thread: permission errors

  1. #1

    permission errors

    Hi guys,
    I'm really not sure what my problem is, so I'll give you all the symptoms.
    First, when I boot up and type startx, I get this error: xauth: time out in locking authority file /home/doron/.Xauthority. This happens four times, then I get the nvidia logo, then it's back to the command line with the same error again.
    When I first installed gentoo, I could only run gui's as root (fluxbox), so I figured I'd copy all of the hidden folders from /root to /home, and I could then run fluxbox. Now that I downloaded gnome, nothing works.
    I logged into fluxbox again, and when I tried to start firefox I got this error:
    (Gecko:18171): libgnomevfs-WARNING **: Unable to create ~/.gnome directory: Permission denied
    Could not create per-user gnome configuration directory `/home/doron/.gnome2/': Permission denied
    I get permission errors all the time, which is why I downloaded gnome cause I figured I'm not smart enough to run fluxbox yet, but it seems I messed something up during the install process.

    So basically, I think as a user, I don't have enough priveliges to create folders and such, so how do I give myself the necessary priveliges (too lazy to go through a thesaurus).

    Sorry for rambling btw.


    btw, I'm running Gentoo

  2. #2

    Re:permission errors

    as root try chown -R user /home/user - i am guessing the directory is own by root.

  3. #3

    Re:permission errors

    also remember to make it owned by the group users (it doesn't matter too much, but hey)
    chown -R user:users /home/user

Similar Threads

  1. NFS & NIS: permission denied
    By dgermann in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 02-28-2006, 03:48 AM
  2. NFS permission problem:
    By ritesh in forum Linux - General Topics
    Replies: 1
    Last Post: 08-15-2005, 09:39 PM
  3. SMB permission propagation?
    By Tyr_7BE in forum Linux - Hardware, Networking & Security
    Replies: 17
    Last Post: 02-21-2005, 12:06 AM
  4. permission denied
    By rwtoften in forum Linux - General Topics
    Replies: 4
    Last Post: 06-10-2002, 02:57 AM
  5. permission denied, wtf?
    By boblucci in forum Linux - General Topics
    Replies: 20
    Last Post: 11-30-2001, 12:19 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts