Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: getting the right version of glib......

  1. #1

    getting the right version of glib......

    hi all!
    well, i just bought an old omnibook 6000 and installed mdk 10 on it.

    it all works well and it's alot more 'snappy' than i remember from back when i used slackware (6 or 5 or something like that) -linux has come a long way!

    but, yesterday i tried to intall xmms on it and when i try to run the ./configure script i ran into trouble on:
    checking for GLIB - version >= 1.2.2...
    -i don't remember exactly what it said -but the idea was that it couldn't find glib (i guess that it has glib 2.something...)
    so i installed glib 1.2.10 and it still didn't work
    so i read somewhere that there was a difference in how glib was registered on systems from 1.2.8 and upwards -so i installed 1.2.7.

    NOW i get this:
    checking for GLIB - version >= 1.2.2...
    *** 'glib-config --version' returned 1.2.7, but GLIB (1.2.10)
    *** was found! If glib-config was correct, then it is best
    *** to remove the old version of GLIB. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If glib-config was wrong, set the environment variable GLIB_CONFIG
    *** to point to the correct copy of glib-config, and remove the file config.cache
    *** before re-running configure
    no
    configure: error: *** GLIB >= 1.2.2 not installed - please install first ***checking for GLIB - version >= 1.2.2...
    *** 'glib-config --version' returned 1.2.7, but GLIB (1.2.10)
    *** was found! If glib-config was correct, then it is best
    *** to remove the old version of GLIB. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If glib-config was wrong, set the environment variable GLIB_CONFIG
    *** to point to the correct copy of glib-config, and remove the file config.cache
    *** before re-running configure
    no
    configure: error: *** GLIB >= 1.2.2 not installed - please install first ***

    so, i guess i should uninstal 1.2.10 -how do i do this?

    -any ideas and tips would be VERY welcome!

    \slideshow-bob

  2. #2
    Guest

    Re:getting the right version of glib......

    this is most likely because you don't have the -devel package of glib installed

    lemme give you some real good advice: if you're using an RPM based system (which Mandrake is), avoid installing stuff from source at all time. Instead, try to install as much as possible by using RPM packages that were created specifically for Mandrake.

    if you do wanna install from source however, install the glib-devel package that should be on your mandrake CD's

    but trust me on this one, it's always best to exclusively use the packaging system of your distro

  3. #3

    Re:getting the right version of glib......

    ok -sounds like good advice, -but:
    when i enter the system-manager in kde and select add software i select the dev-package -it asks me for mdk-cd 4 -but that is not available for free...

    -so, any ideas? -pointers? -recipes for cranberry pie?
    -i tried to run the install-cd's and add the packages that way, but no go..

    \slideshow-bob

  4. #4
    Guest

    Re:getting the right version of glib......

    this is a great site for searching for RPMs... just be sure to select only the distro that you're using

  5. #5

    Re:getting the right version of glib......

    ok, hmmm -it might just be my fault (that's what my girlfriend always claims, anyway... :P)

    -but i can't find any rpm's on this site... (maybe you forgot a link or something... ?)
    -and i've tried rpmfinder or something and no go..

    so, i actually reinstalled the whole system from scratch, format and everything...

    -the thing is:
    -when i try all the fixes ppl are suggesting (it seems that i'm NOT alone in having this problem on mdk10)

    i still only get back to the inescapable fact that i DO have 1.2.10 installed (from the start, apparantly..) -but it is not being recognized by the ./configure script
    -editing glib-conf doesn't help,

    -so -any ideas?

    \slideshow-bob

  6. #6

    Re:getting the right version of glib......

    You might need to add it to your PATH, or indicate where it is when doing ./configure.

    Code:
    ./configure --with-glib=/path/to/glib
    try
    Code:
    ./configure --help
    for the appropiate way of doing it.

    Or, to add it to the PATH, edit the file /etc/profile, and add the path to the library to your list of paths. Then log off and log back on.

  7. #7

    Re:getting the right version of glib......

    ok -will try (later tonight -the batteries are out of juice -and i forgot the bl**dy power-adapter)

    -but the only glib-related directory i can remember finding is the gtk one....
    -any ideas on where it might be?

    -also, when i've used PATH=$PATH in the past -i haven't been able to att directories to it -should i add a specific file or should i use a flag of some sort for PATH?



    -cheers,
    \slideshow-bob

  8. #8

    Re:getting the right version of glib......

    Try
    Code:
    whereis glib
    You'd add to your list of paths, the location of glib.


    You have to be root to edit /etc/profile.

  9. #9
    Guest

    Re:getting the right version of glib......

    [quote author=slideshow-bob link=board=1;threadid=9553;start=0#msg87055 date=1090682952]
    but i can't find any rpm's on this site... (maybe you forgot a link or something... ?)
    [/quote]

    i didn't forget the link, you're just supposed to fill in the fields and select the appropriate system. if i fill in glib-devel and select Mandrake 10 i get 3 results (1,2 and 3)

    but like i said, it's better to just use RPMs all the time on an rpm based system so if you search for xmms for mandrake 10 on that site i gave you, you'll get some more results, the best one probably being this one

  10. #10
    Guest

    Re:getting the right version of glib......

    [quote author=slideshow-bob link=board=1;threadid=9553;start=0#msg87055 date=1090682952]
    i still only get back to the inescapable fact that i DO have 1.2.10 installed (from the start, apparantly..) -but it is not being recognized by the ./configure script
    [/quote]

    and this would be because you probably don't have the -devel package installed, like i already mentioned

    seriously, just install xmms from rpms (or anything else for that matter)

Similar Threads

  1. How to Upgrade glib
    By nagaraj_ccna in forum Redhat / Fedora
    Replies: 7
    Last Post: 04-03-2006, 01:46 AM
  2. How to Upgrade glib
    By nagaraj_ccna in forum General Chat
    Replies: 7
    Last Post: 04-03-2006, 01:46 AM
  3. GLIB - Fedora - I'manewbie
    By clayharryman in forum Linux - General Topics
    Replies: 4
    Last Post: 02-10-2005, 02:49 AM
  4. Problems with glib
    By Aikawa-kun in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 02-11-2004, 09:40 PM
  5. Where can I find glib-dev
    By CP in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 06-07-2002, 11:26 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •