Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ..../includes/class_bbcode.php on line 2962

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Compiling and installing
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Compiling and installing

  1. #1
    Member
    Join Date
    Apr 2004
    Location
    Atlanta, GA
    Posts
    215

    Compiling and installing

    I just installed the new version of Gaim. On several machines, this has been no big deal, but on my workstation at work, I've never been able to get the gaim-encryption plugin to compile quite right. Since upgrading a few hours ago, I downloaded the source for gaim-encryption, and muddled it a little, and finally got it to compile.

    :w00t: :w00t: :w00t:

    Another small victory.

    Just thought I'd share.

    Anyone else have a single app that just never seems to compile/install smoothly?

  2. #2
    Member
    Join Date
    Apr 2004
    Location
    Atlanta, GA
    Posts
    215
    btw, This is my 100th post at LF! :w00t: :cow: :w00t:

  3. #3
    Advisor beezlebubsbum's Avatar
    Join Date
    May 2004
    Location
    Australia
    Posts
    735
    I love the feeling of getting the software to compile properly, especially if it is a troublesome one like the one you were talking about. Well done Gruntled! Also, well done on the 100th post!
    My Website:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    My Website Uptime:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    My Server Specs: AMD Athlon X2 3800+, 2gb DDR2 RAM, 1.5TB HDD, Ubuntu 9.10
    My Gaming PC: Intel Core 2 Duo 2.93ghz, 4gb DDR2 RAM, 9800GTX+

  4. #4
    Member
    Join Date
    Apr 2004
    Location
    Eugene, Oregon
    Posts
    207
    Ugh...one of the reasons I'm a diehard Debian guy is that I always have such a rotten time with the old configure, make sequence of installs. For those of us with no programming background it's terribly confusing when the configure script blows up complaining that it can't find your X includes path (whatever that is) or some other thing-it-needs that you're pretty sure exists on your system, but even if you knew the path to, you wouldn't know how to tell the script.

    I much prefer dpkg -i package

  5. #5
    Mentor
    Join Date
    May 2004
    Location
    Louisiana
    Posts
    1,206
    Kung, You said, "I much prefer dpkg -i package"

    How about a link or your own tutoral on dpkg?

  6. #6
    Mentor
    Join Date
    May 2004
    Location
    Louisiana
    Posts
    1,206
    tutorial, tutorial, tutorial.

    Took the end of my finger off a couple of years ago, still have trouble getting to some keys!

  7. #7
    Senior Member
    Join Date
    Apr 2004
    Location
    Atlanta GA
    Posts
    373
    well you know. debs only work on debian systems, .rpms on red-hat-ish systems, and even my own gentoos ebuild are entirely distro dependant. That why I think it is important to know what your doing as far as the compilation adn installation of software fromm scratch is concearned. I mean, what if you were trying to help a friend on a different distro. or better, what if you were commisioned to install a few different systems for some reason using different distros. ya never know when it comes in handy

  8. #8
    Advisor beezlebubsbum's Avatar
    Join Date
    May 2004
    Location
    Australia
    Posts
    735
    There is nothing like good ol' debian! The only quibble I have is that apt doesn't have some programs that I would like. And it always downloads the newest, so sometimes you have to update other components!
    My Website:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    My Website Uptime:
    To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

    My Server Specs: AMD Athlon X2 3800+, 2gb DDR2 RAM, 1.5TB HDD, Ubuntu 9.10
    My Gaming PC: Intel Core 2 Duo 2.93ghz, 4gb DDR2 RAM, 9800GTX+

  9. #9
    Member
    Join Date
    Apr 2004
    Location
    Atlanta, GA
    Posts
    215
    I had big troubles installing php5. I got apache2, mysql 4.0.20, updated Perl, etc etc. Then I went to install the latest php5 and it just wouldn't work. It would always either choke on (or skip entirely) the creation of the libphp5.so file for Apache. I kept trying different options and specifying absolute paths, and finally gave up and installed 4.3.8, qhich installed without a hitch, and not only created the libphp4.so file, but also updated my httpd.conf to link it.

    I'm thinking it may have something to do with my aging distro on my workstation. I'm going to do a data backup and try out Slackware 10 as soon as I can find a free hour or so...

  10. #10
    Senior Member
    Join Date
    Apr 2004
    Location
    Atlanta GA
    Posts
    373
    ***Shameless plug for Gentoo***

    Give Gentoo a shot, I guarentee you will love it, or your money back

Similar Threads

  1. compiling
    By friskydrifter in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 07-23-2002, 02:55 AM
  2. Compiling PHP-4.2.1
    By Ashcrow in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 06-30-2002, 09:59 PM
  3. Help compiling/installing/configuring XFree 4.2.
    By otheos in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 03-29-2002, 06:59 PM
  4. Help with compiling GLE...
    By Daedra in forum Linux - General Topics
    Replies: 3
    Last Post: 03-01-2002, 10:24 PM
  5. LFS - Help - Compiling gcc
    By gmoreno in forum Linux - General Topics
    Replies: 6
    Last Post: 02-10-2002, 02:58 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •