Results 1 to 5 of 5

Thread: Samba Problem

Hybrid View

  1. #1

    Samba Problem

    Hi,

    I need help in setting up samba.I have windows 2000 as domain server and and i made one new linux system and now I want to join with windows 2000 server which i did it easily.Now i want to give access to some users to access application which is installed on Linux System.I tried to configure samba and when I click the linux system on network places it ask for password and user name.and were as i mentioned in my samba to whom I want to give access to use the application as valid user = adminsitartor,user1,user2.So when I log in as user1 or any other user it ask for the username and password.

    Can any one tell me whats wrong with configuring samba,.
    Thz
    Rishi

  2. #2

    Re:Samba Problem

    hello,
    can you post your smb.conf file, at least the sections that have the access level & type.

  3. #3

    Re:Samba Problem

    Hi
    Yeah I am sending SMB.conf file plz check.I've got hooked up of this problem in configuring my samba server to be
    seen in the network neighborhood of Windows 95/98 OS. It always asking
    to supply a Username and password for the resources \system

    This dialog box always comes when I try to access to logon on my samba
    system on network.

    Incorrect password or unkown user for

    \system.

    Connect As.........
    password............


    I am using Linux 7.2 with samba 3.0.1

    workstation are windows95/98/2000 server/Xp

    Hope that somebody will reply to my problem.

    Thanks
    Rishi


    [homes]
    comment = Home Directories
    browseable = no
    writable = yes

    # Un-comment the following and create the netlogon directory for Domain Logons
    ; [netlogon]
    ; comment = Network Logon Service
    ; path = /usr/local/samba/lib/netlogon
    ; guest ok = yes
    ; writable = no
    ; share modes = no


    # Un-comment the following to provide a specific roving profile share
    # the default is to use the user's home directory
    ;[Profiles]
    ; path = /usr/local/samba/profiles
    ; browseable = no
    ; guest ok = yes


    # NOTE: If you have a BSD-style print system there is no need to
    # specifically define each individual printer
    [printers]
    comment = All Printers
    path = /usr/spool/samba
    browseable = no
    # Set public = yes to allow user 'guest account' to print
    guest ok = no
    writable = no
    printable = yes

    # This one is useful for people to share files
    ;[tmp]
    ; comment = Temporary file space
    ; path = /tmp
    ; read only = no
    ; public = yes

    # A publicly accessible directory, but read only, except for people in
    # the "staff" group
    ;[public]
    ; comment = Public Stuff
    ; path = /home/samba
    ; public = yes
    ; writable = yes
    ; printable = no
    ; write list = @staff

    # Other examples.
    #
    # A private printer, usable only by fred. Spool data will be placed in fred's
    # home directory. Note that fred must have write access to the spool directory,
    # wherever it is.
    ;[fredsprn]
    ; comment = Fred's Printer
    ; valid users = fred
    ; path = /homes/fred
    ; printer = freds_printer
    ; public = no
    ; writable = no
    ; printable = yes

    # A private directory, usable only by fred. Note that fred requires write
    # access to the directory.
    [Creative]
    comment = data
    path = /data/Creative
    valid users = administrator,turishi,sudevan,djoshi,sgauri,rbisht ,aarora,mmpathak,nkaimal,vsarna,gdiwan,acyrill,sak umar,srsingh,aprasad,snsharma,sdawar,everma,vmisra ,tvirmani,strikha,hvedi,svsrinath,smohan,psaxena,s dubey,mbarodia,dmohan,aray
    admin users = administrator,turishi
    public = no
    writable = yes
    printable = no
    create mode = 767
    force create mode = 767
    ; create mask = 0775
    directory mode = 0767
    force directory mode = 767
    ; delete veto files = no
    share modes = yes

    [Logos]
    comment = data
    path = /data/Creative/Logos
    ; read list = @dummyi
    valid users = administrator,turishi,sudevan,djoshi,sgauri,rbisht ,aarora,mmpathak,nkaimal,vsarna,gdiwan,acyrill,sak umar,srsingh,aprasad,snsharma,sdawar,everma,vmisra ,tvirmani,strikha,hvedi,svsrinath,smohan,psaxena,s dubey,mbarodia,dmohan,aray
    admin users = administrator
    public = no
    writable = yes
    printable = no
    create mode = 767
    force create mode = 767
    ; create mask = 0775
    directory mode = 0767
    force directory mode = 767
    ; delete veto files = no

    [CDFONTS]
    comment = data
    path = /data/Creative/CDFONTS
    valid users = administrator,turishi,sudevan,djoshi,sgauri,rbisht ,aarora,mmpathak,nkaimal,vsarna,gdiwan,acyrill,sak umar,srsingh,aprasad,snsharma,sdawar,everma,vmisra ,tvirmani,strikha,hvedi,svsrinath,smohan,psaxena,s dubey,mbarodia,dmohan,aray
    admin users = administrator,turishi
    public = no
    writable = yes
    printable = no
    create mode = 767
    force create mode = 767
    ; create mask = 0775
    directory mode = 0767
    force directory mode = 767
    ; delete veto files = no

  4. #4

    Re:Samba Problem

    hello,
    sorry for taking so long to respond - anywho, do you have the global section?
    Code:
    [global]
    
    
       workgroup = MYGROUP
    
    
       server string = Samba Server
    
    # This option is important for security. It allows you to restrict
    # connections to machines which are on your local network. The
    # following example restricts access to two C class networks and
    # the "loopback" interface. For more examples of the syntax see
    # the smb.conf man page
    ;   hosts allow = 192.168.1. 192.168.2. 127.
    
    # if you want to automatically load your printer list rather
    # than setting them up individually then you'll need this
       printcap name = /etc/printcap
       load printers = yes
    
    # It should not be necessary to spell out the print system type unless
    # yours is non-standard. Currently supported print systems include:
    # bsd, sysv, plp, lprng, aix, hpux, qnx, cups
       printing = cups
    
    # Uncomment this if you want a guest account, you must add this to /etc/passwd
    # otherwise the user "nobody" is used
    ;  guest account = pcguest
    
    # this tells Samba to use a separate log file for each machine
    # that connects
       log file = /var/log/samba/%m.log
    
    # Put a capping on the size of the log files (in Kb).
       max log size = 0
    
    # Security mode. Most people will want user level security. See
    # security_level.txt for details.
       security = user
    this is an example, i have the security set to user and it has worked well for me. i have not needed it for a while though...

  5. #5

    Re:Samba Problem

    Hi Pbharris ,

    I can't give security=users as I want to give limited access to the users.If I set this option then it allows everyone to access the application.

    Anyways I tried this also to check whether it works but it still is asking for user name and password.

    Thanks
    Turishi

Similar Threads

  1. Slackware 12 and Samba Problem
    By johnmann in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 03-27-2008, 07:44 PM
  2. Problem with Samba, Please help me...
    By Muhammad A. Husain in forum General Chat
    Replies: 1
    Last Post: 10-29-2007, 07:52 PM
  3. Samba Problem
    By turishi007 in forum Linux - General Topics
    Replies: 2
    Last Post: 10-17-2004, 03:32 AM
  4. samba problem, browsing
    By pasholy in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 08-20-2002, 05:11 AM
  5. Samba problem - Can not ping
    By lhvan in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 07-10-2002, 04:22 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •