Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
HELP! no sound for non-root user
Results 1 to 10 of 10

Thread: HELP! no sound for non-root user

  1. #1

    HELP! no sound for non-root user

    Slackware 9.1, KDE, ASLA

    Under root, CD(KsCD), VCD(xine), mp3/wav(kaboodle) all works fine, nice X11 login/logout sound effects...

    Under non-root, only CD still works.
    I will state the problem in time-order...
    After I finished all the sound testing under root, I log back in as a non-root. The login sound effect (when KDE's loading) came out, but mixed with some noise, and that's the first and the last time i hear the login sound effect.
    After I login, the arts server warned on permission on artswrapper, so I did the chmod 4755 artswrapper, and the i never see that warning again.
    After visiting the arts website, I chmod 666 /dev/dsp, /dev/audio, but still no sound. And I've checked the mixer setting to make sure nothing's muted.
    With Arts control tool open, the volume indicator on the control tool does show the volume when I play the test sound or mp3, but nothing from the speaker...

    someone please help!

  2. #2

    Re:HELP! no sound for non-root user

    Try checking /etc/group. Is there an "audio" group? Try adding your username to that group if it exists (I'm sure KDE has some sort of tool to do that).

  3. #3

    Re:HELP! no sound for non-root user

    [quote author=Tyr_7BE link=board=1;threadid=9369;start=0#msg84887 date=1087708164]
    Try checking /etc/group. Is there an "audio" group? Try adding your username to that group if it exists (I'm sure KDE has some sort of tool to do that).
    [/quote]

    Nope, there's no such group.
    An additional note, the system test sound (single beep) also works under non-root.

  4. #4

    Re:HELP! no sound for non-root user

    [quote author=bli1348 link=board=1;threadid=9369;start=0#msg84889 date=1087709254]
    [quote author=Tyr_7BE link=board=1;threadid=9369;start=0#msg84887 date=1087708164]
    Try checking /etc/group. Is there an "audio" group? Try adding your username to that group if it exists (I'm sure KDE has some sort of tool to do that).
    [/quote]

    Nope, there's no such group.
    An additional note, the system test sound (single beep) also works under non-root.
    [/quote]
    Furthermore, still nothing out of speaker even if I add this non-root account under the root group.

  5. #5
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:HELP! no sound for non-root user

    Check all alsa volumes. By default all are muted. You need to unmute them, you also need to raise the master and PCM to hear any sound.
    CP

  6. #6
    Guest

    Re:HELP! no sound for non-root user

    not sure if this will fix anything but play some music, open kmix, press the Advanced checkbox and try enabling/disabling every setting you see there.

    i've heard that ALSA can act really weird with the wrong combination of those settings

  7. #7

    Re:HELP! no sound for non-root user

    I had that same issue.
    The first workaround I tried was to, every time I logged in, as a regular use, open a command window, then do an su, and run alsamixer from there. The sound came back right away.
    Afterwards, I ran alsamixer, then alsactl save to save my settings, and then alsactl restore at bootup.
    Not happy with that, later I returned to OSS from Alsa. But the sound was not that good.
    Later on I installed Dropline Gnome, and I think something in their package fixed stuff for me.

    I'd say try those sugestions from the top.

  8. #8

    Re:HELP! no sound for non-root user

    Wouldn't throwing alsamixer into rc.local fix this?

  9. #9

    Re:HELP! no sound for non-root user

    [quote author=Corrupt Countach44 link=board=1;threadid=9369;start=0#msg84903 date=1087739149]
    Wouldn't throwing alsamixer into rc.local fix this?
    [/quote]
    I *seem* ro recall that not working. However, I might be wrong.

  10. #10

    Re:HELP! no sound for non-root user

    it's solved.
    Same idea of adding the user to the audio group, but under slackware 9.1 default, the group is sys.

    However, if it's just permission problem, chmod should solve the problem as well. Don't know what files need to be chmoded other than the ones i've done >

Similar Threads

  1. CUPS Admin/Root User
    By gmoreno in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 03-09-2005, 04:48 AM
  2. adding another root user
    By Blaqb0x in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 03-20-2003, 02:00 AM
  3. Root user
    By vwgtiturbo in forum Linux - General Topics
    Replies: 1
    Last Post: 11-27-2002, 03:30 AM
  4. mplayer runs as root, but not as user
    By S_D_Willie in forum Linux - General Topics
    Replies: 12
    Last Post: 10-04-2002, 07:52 PM
  5. running programs as root and a plain old user
    By tolstoy in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 09-20-2002, 04:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •