Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
nfs exports not mounting :/
Results 1 to 7 of 7

Thread: nfs exports not mounting :/

  1. #1
    Mentor Stuart's Avatar
    Join Date
    May 2002
    Location
    nb.ca
    Posts
    1,087

    nfs exports not mounting :/

    Ok, heres the deal. Got two machines, Darkstar, and John5.
    Here is my /etc/exports on Darkstar:

    Code:
    /mnt/cdrom      (insecure,no_root_squash,rw)
    root@john5:~# mount -t nfs darkstar:/mnt/cdrom /mnt/cdrom
    mount: darkstar:/mnt/cdrom failed, reason given by server: Permission denied
    Ideas?

  2. #2
    Guest

    Re:nfs exports not mounting :/

    Did u setup hosts.allow? Is nfsd running? Does the slave comp know who darkstar is? Here is a link to a troubleshooting section. http://nfs.sourceforge.net/nfs-howto...eshooting.html

  3. #3
    Mentor Stuart's Avatar
    Join Date
    May 2002
    Location
    nb.ca
    Posts
    1,087

    Re:nfs exports not mounting :/

    I did not setup hosts.allow, and I could swear I had this working a month ago :/

    Okay, most of these errors I can live with.
    Code:
    root@darkstar etc # exportfs -ra
    exportfs: No host name given with /mnt/cdrom (insecure,no_root_squash,ro), suggest *(insecure,no_root_squash,ro) to avoid warning
    exportfs: /etc/exports [1]: No 'sync' or 'async' option specified for export ":/mnt/cdrom".
      Assuming default behaviour ('sync').
      NOTE: this default has changed from previous versions
    john5.home:/mnt/cdrom: Invalid argument
    But the last one just confuses the hell out of me. Where is it getting that ???

  4. #4
    Guest

    Re:nfs exports not mounting :/

    What is john5.home?

  5. #5
    Mentor Stuart's Avatar
    Join Date
    May 2002
    Location
    nb.ca
    Posts
    1,087

    Re:nfs exports not mounting :/

    from /etc/hosts
    Code:
    192.168.1.2     john5.home john5

  6. #6

    Re:nfs exports not mounting :/

    try:

    /mnt/cdrom -ro john5 host2 host3


    then run portmap, and restart mountd, and nfsd.

  7. #7
    Mentor Stuart's Avatar
    Join Date
    May 2002
    Location
    nb.ca
    Posts
    1,087

    Re:nfs exports not mounting :/

    Ok, exports are working, rpc is working, however it is taking ages it seems to mount the nfs share, and I am not sure if it's going to mount at all.
    :/

Similar Threads

  1. Mounting help
    By SunDevil in forum Linux - General Topics
    Replies: 4
    Last Post: 10-23-2002, 08:13 AM
  2. Help With Mounting
    By netviper13 in forum Windows - General Topics
    Replies: 8
    Last Post: 10-23-2002, 07:15 AM
  3. Mounting
    By Micahizme in forum Redhat / Fedora
    Replies: 9
    Last Post: 08-28-2002, 03:10 AM
  4. Mounting a Cd
    By Feztaa in forum Linux - Hardware, Networking & Security
    Replies: 11
    Last Post: 12-31-2001, 04:56 AM
  5. mounting an iso?
    By krinkstar in forum Linux - General Topics
    Replies: 7
    Last Post: 12-04-2001, 09:11 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •