Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: alsa troubles

  1. #1

    alsa troubles

    using slackware 9.1, my alsa has worked on and off and now it just doesnt work at all anymore when i choose to use it as the plugin in xmms. and so now im using the oss driver and my sound just sounds like shit. i was thinking maybe if i upgrade alsa to 1.0.4 latest. i used to be able to use at least alsamixer and it would recognize my soundblaster live 5.1 pci card. now when i use alsaconf it doesnt find my soundcard, and when i type alsamixer i get...

    alsamixer: function snd_ctl_open failed for default: No such device

    when i type xmms and try to play a song and get in the console

    ** WARNING **: alsa_get_mixer(): Attaching to mixer hw:0: No such device

    ** WARNING **: alsa_setup(): Failed to open pcm device (default): No such device
    and i also get a grey popup box that says

    Please check that:

    Your soundcard is configured properly
    You have the correct output plugin selected
    No other program is blocking the soundcard

    ive chmod 777 /dev/dsp and mixer and pcm but nothing, however i do get sound with any other plugin but alsa. i just want to see if alsa when working can make my sound better since i have static in my sound.

  2. #2

    Re:alsa troubles

    hello,
    are the modules loaded?

  3. #3

    Re:alsa troubles

    ya, emu10k1 is loaded

  4. #4

    Re:alsa troubles

    Can you post the output of 'lsmod'?

  5. #5

    Re:alsa troubles

    Module Size Used by Not tainted
    ntfs 50848 1 (autoclean)
    ipt_state 536 2 (autoclean)
    ipt_REJECT 3192 1 (autoclean)
    ipt_LOG 3448 1 (autoclean)
    iptable_filter 1644 1 (autoclean)
    ip_nat_ftp 2704 0 (unused)
    iptable_nat 15640 2 [ip_nat_ftp]
    ip_conntrack_irc 3024 0 (unused)
    ip_conntrack_ftp 3856 1
    ip_conntrack 19592 4 [ipt_state ip_nat_ftp iptable_nat ip_conntrack_irc ip_conntrack_ftp]
    ip_tables 12288 7 [ipt_state ipt_REJECT ipt_LOG iptable_filter iptable_nat]
    keybdev 1952 0 (unused)
    mousedev 4244 0 (unused)
    hid 21156 0 (unused)
    input 3200 0 [keybdev mousedev hid]
    usb-ohci 18888 0 (unused)
    usbcore 58752 1 [hid usb-ohci]
    sis900 12684 1
    crc32 2880 0 [sis900]
    emu10k1-gp 1352 0 (unused)
    gameport 1452 0 [emu10k1-gp]
    emu10k1 57096 0
    sound 55636 0 [emu10k1]
    ac97_codec 12296 0 [emu10k1]
    soundcore 3332 7 [emu10k1 sound]
    ide-scsi 9424 0
    agpgart 44100 0 (unused)
    was having a hard time pasting this, xfce wouldnt let me cut and paste stutf but gnome did it. ???

  6. #6

    Re:alsa troubles

    is the modules.conf modified for alsa? i tink that is an oss module - iir the alsa module is called snd-emu10k1

  7. #7

    Re:alsa troubles

    [quote author=burntash link=board=1;threadid=9058;start=0#msg81983 date=1082355632]
    Module Size Used by Not tainted
    ntfs 50848 1 (autoclean)
    ipt_state 536 2 (autoclean)
    ipt_REJECT 3192 1 (autoclean)
    ipt_LOG 3448 1 (autoclean)
    iptable_filter 1644 1 (autoclean)
    ip_nat_ftp 2704 0 (unused)
    iptable_nat 15640 2 [ip_nat_ftp]
    ip_conntrack_irc 3024 0 (unused)
    ip_conntrack_ftp 3856 1
    ip_conntrack 19592 4 [ipt_state ip_nat_ftp iptable_nat ip_conntrack_irc ip_conntrack_ftp]
    ip_tables 12288 7 [ipt_state ipt_REJECT ipt_LOG iptable_filter iptable_nat]
    keybdev 1952 0 (unused)
    mousedev 4244 0 (unused)
    hid 21156 0 (unused)
    input 3200 0 [keybdev mousedev hid]
    usb-ohci 18888 0 (unused)
    usbcore 58752 1 [hid usb-ohci]
    sis900 12684 1
    crc32 2880 0 [sis900]
    emu10k1-gp 1352 0 (unused)
    gameport 1452 0 [emu10k1-gp]
    emu10k1 57096 0
    sound 55636 0 [emu10k1]
    ac97_codec 12296 0 [emu10k1]
    soundcore 3332 7 [emu10k1 sound]
    ide-scsi 9424 0
    agpgart 44100 0 (unused)
    was having a hard time pasting this, xfce wouldnt let me cut and paste stutf but gnome did it. ???
    [/quote]

    It's probably the age-old cut-n-paste under linux problem. Too many clipboard standards and everyone wants to use their own. Google for a little utility called "gnome-clipboard-daemon". It can be used under Gnome, KDE, XFCE, Blackbox, etc etc... Make it start when XFCE is started and you're good to go. It's just a little background process that unifies all the clipboards. Handier than you can believe.

    And I agree with pbharris. Take a look around for howto's on getting alsa up and running (be warned...there's a mammoth amount of documentation out there but almost all of it is vague and convoluted...you may have to do some serious mining). Most howto's involve modifying your modules.conf file to load up the appropriate modules under /lib/modules/kernelversion/...... (the exact path varies depending on whether you're using 2.4 or 2.6...they'll always be under /lib/modules/kernelversion/ though). You might actually want to play around with modules like snd-emu10k1 with modprobe first and see if you can't get them up and running that way.

  8. #8

    Re:alsa troubles

    hm my /etc/modules.conf is empty

    i uncommented anything having to do with emu10k1 though in my /etc/rc.d/rc.modules and it only had emu10k under OSS and Gameports. there was nothin for alsa.

  9. #9

    Re:alsa troubles

    hello,
    here is what i have for my alsa module options
    Code:
    # ALSA portion
    alias char-major-116 snd
    alias snd-card-0 snd-emu10k1
    # module options should go here
    
    # OSS/Free portion
    alias char-major-14 soundcore
    
    # card #1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss

  10. #10

    Re:alsa troubles

    and you have that in your /etc/modules.conf ?

Similar Threads

  1. Sound Driver Alsa
    By rprakash65 in forum Linux - General Topics
    Replies: 2
    Last Post: 01-01-2009, 08:14 PM
  2. Alsa devices
    By CP in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 07-13-2004, 06:53 AM
  3. Quake 3 no sound with alsa
    By BizKiT in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 04-22-2003, 02:24 PM
  4. ALSA, kernel 2.4.20
    By teknik0s in forum Linux - Hardware, Networking & Security
    Replies: 16
    Last Post: 03-28-2003, 02:28 PM
  5. ALSA
    By in forum Linux - General Topics
    Replies: 3
    Last Post: 04-20-2002, 06:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •