Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
DOesnt let me do ./configure
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: DOesnt let me do ./configure

  1. #1
    Junior Member
    Join Date
    Feb 2004
    Posts
    72

    DOesnt let me do ./configure

    I have tried installing a few things that came with a DVD.

    Some were RPM and some were tar.gz

    I was able to unpack all

    The problem occures when i try to do a

    ./configure

    or

    ./configure --enable-gnome

    It says something about:

    BASH: /bin/sh Not permitted

    I will get the exact error and put it on the forum tommorrow

    This problem is so fustrrating as i cannot install anything, this problem has occured every time i try and install an RPM or a tar.gz

    Some examples are when tryung to install WINE, XINE, ROX ENVIRONMENT etc...

    Any help would be much apreciated

  2. #2

    Re:DOesnt let me do ./configure

    You do not decompress RPM Packages. You just install them. On the Plain English Tutorials section, we have a good tutorial on using them.

    As for tat.gz files, those you do decompress. Afterwards, look for the INSTALL or README file on it. It should give you detailed instructions.

  3. #3
    Junior Member
    Join Date
    Feb 2004
    Posts
    72

    HELP!

    Ok heres the problem:

    I can unpack the tar.gz files then when i do a ./CONFIUGURE like it sais to do then it gives this error message.

    Bash: ./configure: /bin/sh: Bad Interpreter: Permisson Denied
    This occurs when in root aswell.

    ALso on a side note, i have just installed the fluxbox rpm. How do i make it so that i ca nchoowse to go into fluxbox instead of gnome or kde

  4. #4

    Re:DOesnt let me do ./configure

    hello,
    for redhat edit the file ~/.Xclients-default and put exec fluxbox (assumes fluxbox is in your path).

    for the bad interpetor - what happens when you type sh ?

  5. #5
    Guest

    Re:HELP!

    [quote author=G/\weph link=board=2;threadid=9013;start=0#msg81541 date=1081852011]
    Bash: ./configure: /bin/sh: Bad Interpreter: Permisson Denied
    This occurs when in root aswell.
    [/quote]

    Is sh installed? If so, is it installed under /bin/, you may want to run `whereis sh' just to be certain. Either install sh or link it to /bin/sh.

    Good luck.

  6. #6
    Junior Member
    Join Date
    Feb 2004
    Posts
    72

    Re:DOesnt let me do ./configure

    I asume it is installed. In the users area its a choice of login shell.

  7. #7
    Junior Member
    Join Date
    Feb 2004
    Posts
    72

    Re:DOesnt let me do ./configure

    I ckecked and \bin\sh isa choice of login shell. DOes thius mean that it is installed.

    Where do i find ~/.Xclients-default. Is it just hidden in \

    Also was wondering if there is an appolication, or somne command that can be typed in theterminal, that will show all packages that are currently on my system.

    Thanks for replyinjmg so far

  8. #8

    Re:DOesnt let me do ./configure

    hello,
    i would not assume that because it is a choice it is installed. what happens when you type sh at the shell?

  9. #9
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re:DOesnt let me do ./configure

    try putting sh before ./configure

    sh ./configure

  10. #10
    Junior Member
    Join Date
    Feb 2004
    Posts
    72

    Re:DOesnt let me do ./configure

    Ok, doing a sh ./configure worked, it starts to do some stuff. it then stops at some point and says something about howq it cannot use C compiled programs.

    Here is what it says:

    [root@localhost xine-lib-1-rc3a]# sh ./configure --enable-gnome
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking target system type... i686-pc-linux-gnu
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    /mnt/MyDrive/Linux: /mnt/MyDrive/Linux: No such file or directory
    configure: WARNING: `missing' script is too old or missing
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking for style of include used by make... GNU
    checking for gcc... gcc
    checking for C compiler default output file name... a.out
    checking whether the C compiler works... configure: error: cannot run C compiled programs.
    If you meant to cross compile, use `--host'.
    See `config.log' for more details.

    Does anyone know what i need to do???

Similar Threads

  1. Mozilla doesnt start
    By friskydrifter in forum Linux Distros
    Replies: 13
    Last Post: 12-16-2011, 10:25 AM
  2. doesnt get much better then this...
    By TeRG in forum General Chat
    Replies: 13
    Last Post: 11-01-2003, 08:19 AM
  3. MOZILLA FIREBIRD DOESNT LIKE PNG!!!
    By sujoki in forum Linux - Software, Applications & Programming
    Replies: 7
    Last Post: 09-20-2003, 09:36 PM
  4. Nvoption doesnt do anything for me?
    By rick420 in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 07-09-2002, 07:44 PM
  5. Can any one tell me why this doesnt work
    By TaraMc in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 06-02-2002, 05:21 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •