Results 1 to 10 of 10

Thread: Aterm on Blackbox

  1. #1

    Aterm on Blackbox

    I just downloaded Aterm because I wanted a transparent terminal and I am using Blackbox. Is there any way to start aterm as soon as BlackBox starts up?

    I tried putting this under my .xinitrc in my /root/

    exec aterm -tr

    but it doesn't work. Any Ideas how to make Aterm show up in the Blackbox Menus or Starting it up as soon as BB starts up? Thanks!

  2. #2

    Re:Aterm on Blackbox

    You should not be startx'ing as root, there is no reason to be root to enter the gui, if you need it once there use su or sudo.

    As for getting it started, where in your .xinitrc did you put it? you want it before the exec blackbox line, after won't work.

  3. #3

    Re:Aterm on Blackbox

    alright! Thanks! got it working! um.. i downloaded a new theme and add it to my

    /usr/X11R6/share/blackbox/styles/

    and it shows up as one of the options but the background is not visible. and there is no /usr/X11R6/share/blackbox/styles/backgrounds

    or ~./blackbox/styles/backgrounds/

    how can I fix this background issue. ?

    Thanks!

  4. #4

    Re:Aterm on Blackbox

    I haven't used blackbox, but maybe there is no background set for your theme? (on purpose) Also, look for patterns in the other themes and see if there's anything related to the background.

  5. #5
    Junior Member
    Join Date
    Sep 2001
    Posts
    96

    Re:Aterm on Blackbox

    Assuming that you unpacked your new theme under your home directory, the background should be in ~/.blackbox/backgrounds

    If it's there, you now need to look at why it's not being displayed. Go into your ~/.blackbox/styles directory and vi newtheme. Scroll down and you should see a line related to the background image. Check that the path is to where the image actually is.

    I use FluxBox, and have found a few themes where the background image line in the style doesn't point to the right place. It might also be worth checking to see what program it uses to set the background as some use xv which may not be installed. Personally I like to use Eterm, so I change the line to read Esetroot /path/to/background. This works for me.

    NB. I can't remember whether Esetroot should have a capital 'E' or not, and don't have internet access at home at the moment so I can't check and post from there.

    Hope this helps, Chris

  6. #6

    Re:Aterm on Blackbox

    Thanks! I will check it out!

  7. #7

    Re:Aterm on Blackbox

    ;D Got it working! Thanks! (i got it working under my normal account as well as root)

  8. #8
    Junior Member
    Join Date
    Sep 2001
    Posts
    96

    Re:Aterm on Blackbox

    Cool. 8) What was the problem?

    Chris

  9. #9

    Re:Aterm on Blackbox

    Like you said it was pointing at the wrong folder for the background. It works awesome now! The thing is all the themes that I installed today had the same problem. ??? BUt thanks for helping me out!

  10. #10
    Junior Member
    Join Date
    Sep 2001
    Posts
    96

    Re:Aterm on Blackbox

    You're welcome, glad I could help! It does seem to be a common problem with Blackbox / FluxBox themes. Easy to fix when you know about it though.

    Chris

Similar Threads

  1. Openbox Aterm Transparency
    By shebang in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 11-25-2004, 10:41 PM
  2. Aterm & Backspace
    By shebang in forum Linux - General Topics
    Replies: 1
    Last Post: 06-27-2004, 01:05 AM
  3. fonts in multi-aterm
    By Stuart in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 02-06-2004, 07:37 PM
  4. aterm default setting
    By Hitokiri_X in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 04-07-2002, 06:46 PM
  5. aterm for Red Hat 7.x
    By Killer_Penguin in forum Linux - Software, Applications & Programming
    Replies: 26
    Last Post: 03-29-2002, 05:43 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •