If you're having trouble in Mandy 9.2 and 10.0 getting Flash to work, try installing (or forcing a reinstall) libstdc++2.10-2.96-0.83mdk.i586.rpm.

BTW, Mandy 10.0 Community is not bad. Still have problems controlling volume with software in XMMS with my SBLive digital sound card, though.