Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Linux Boot and SuSE trouble

  1. #1

    Linux Boot and SuSE trouble

    I no longer consider this a distribution problem so I am migrating it to the Technical support forum:

    I was able to successfull create a new partition for a third operating system. I was determined to get SuSE 9 Pro installed on my machine, but not totally willing to give up all the progress I made in Fedor Core with the help of many of you.

    After some initial trouble, I was able to install SuSE successfully. Windows is still operational as well, but unfortunately, in the process I fear I may have lost Fedora Core. The partition is still there, and in installing SuSE in YaST, instructed the installer to format the new partition I had created. It also wanted to format the existing Linux Swap partition so I let it.

    Now, I can boot windows and I can boot the new SuSE intall, but I can't boot the old Fedora Core install. I tried using the Fedorca Core install disk to rescue boot but that didn't work. Somthing about no kernel. I tried using the boot disk I had created in Fedora, which I had used many times before getting grub up and running a few weeks ago.. But I got the kernel panic message. No init. etc....

    So. Couple things:

    Any chance of rescuing the Fedor Core install?

    In SuSE, I can't even so much as figure out how to connect to the internet. And I get lost VERY quickly in KDE. How do I set up my dialup in SuSE?

    If my Fedora Core install is indeed lost for good, can I allocate the space from that partition into the SuSE partition? If so, how?

    Am I aksing too many questions and taking advantage of the good natured help you have all provided me over the last month? If so, flame me and make it known on my Karma, which I see has been dipping lately, so I assume I am probably irritating at least a few of you...

    You are all kind and may the Gods be with you... Thankee Sai....

    -John of Giliad....

  2. #2

    Re:Linux Boot and SuSE trouble

    What exactly do you mean by "can't boot the old Fedora install"? Is it available at the boot loader? If it's not, then that's an easy fix. You have to edit your /etc/lilo.conf file or your /boot/grub/menu.lst file (whichever you're using) and add a new entry for /dev/hdaX that holds your Fedora partition. The entry should be identical to your SuSE entry, but with a different hda number. See the manual entries for Grub and Lilo for more info.

    If the Fedora option is available, what happens when you select it? Did you give SuSE its own boot partition?

  3. #3

    Re:Linux Boot and SuSE trouble

    I did not give SuSE it's own boot partition. I set the boot loader on the existin suse partition. At least I think I did. As you can tell, I'm not to adept at this...

    The Fedora does not appear to be available in lilo. I will try to edit the /etc/lilo.conf file as you suggested. I have to log out of Windows and into SuSE to do this, so I'll check back.

    I'll write down everything that happens and post again.



  4. #4

    Re:Linux Boot and SuSE trouble

    Just for kicks, I put in the SuSE install disk and attempted to boot an Installed Operating Sytem.

    my options were:
    hda1 : ntfs
    hda3 : ext3
    hda5 : vfat
    hda6 : reiserfs
    hda3 is where the Fedora Istall was/is...

    I selected had3 and got the following:
    INIT: version 2.85 booting
    INIT: No inittab file found
    Enter runlevel:
    I entered 5
    INIT: Entering runlevel: 5
    INIT: No more processes left in this runlevel
    And that's it. This is the the same no matter what runlevel I chose.

    So, I booted up SuSE and went in to the /ect/grub.conf file. This is what it looks like, more or less:
    root (hd0, 5)
    instal ..stage2-/boot/grub/stage2 /boot/grub/stage1 d (hd0, 5) /boot/grub/stage2 0x8000
    (hd0,5) /boot/grub/menu.lst
    Do you think I can modify this file to boot Fedora? If so, what code and where do I insert it?

    What's the prognosis?



  5. #5

    Re:Linux Boot and SuSE trouble

    Hi John,

    Can you show us what partitions you have, and what's on each?

    If you do

    , then
    , it should show you the partition table.
    Be careful not to erase anything there, though!

    Gilead? Are you a gunslinger?

  6. #6

    Re:Linux Boot and SuSE trouble

    If I were I would remember the face of my father and certainly aim with my eye and shoot this f---ing computer! I'm reading The Wolves of the Kalla.....Ah simple life in MidWorld must be..

    Anyway... can I do this from Windows? Cuz I can't figure out how to get online with SuSE and it's a real PAIN IN THE ASS to reboot over and over again...

  7. #7

    Re:Linux Boot and SuSE trouble

    Heh. My girlfriend gave me that book for Valnetine's but i can't read it yet (no time.)

    You can some from Windows, but it won't show you what's installed on all non-windows partitions

    I'd say just write it down on a piece of paper...

  8. #8

    Re:Linux Boot and SuSE trouble

    Between Linux and The Gunslinger, my wife is on the verge of leaving me... she didn't know she married a geek. I put on a pretty good show...

    OK, well, I'll but up SuSE and try that later. IN the meantime. I have to go cast my ballot for Mondale.

    Thanks, I post the results later... possible tonight.

    -May your days be long....

  9. #9

    Re:Linux Boot and SuSE trouble

    Modify the root entry for fedora, i am guessing yours should be like this:

    title fedora(2.6.1-1.131)
            root (hd0,0)
            kernel /boot/vmlinuz-2.6.1-1.131 ro root=/dev/hda3
            initrd /boot/initrd-2.6.1-1.131.img
    title suse 2.4.22
            root (hd0,0)
            kernel /boot/vmlinuz-2.4.22 ro root=/dev/hda6
            initrd /boot/initrd-2.4.22.img
    title posOS
    rootnoverify (hd0,0)
    chainloader +1
    the run grub-install from ethier suse or a rescue CD

  10. #10

    Re:Linux Boot and SuSE trouble

    Here is my partition table:
    Command (m for help): Disk /dev/hda: 30.0 GB, 30005821440 bytes
    240 heads, 63 sectors/track, 3876 cylinders
    Units = cylinders of 15120 * 512 = 7741440 bytes
    Device Boot      Start     End     Blocks        Id   System
    /dev/hda1            69      2097   15339208+  17   Hidden HPFS/NTFS
    /dev/hda2          2098    2995   6788880      f     Win95 Ext'd (LBA)
    /dev/hda3          2996    3876   6660360      83   Linux
    /dev/hda4             1       68       514048+      82  Linux swap
    /dev/hda5          2098    2111   105808+      b    Win95 FAT32
    /dev/hda6          2112    2995   6683008+    83  Linux
    Partition table entries are not in disk order
    The layout is probably a bit off, but you get the idea from the information.

    To me, it appears as though the partition with Fedora on it has been untouched. The problem lies in booting it up. Will that rescue disk your sending me help solve a problem like this. Boy, I kinda wish I hadn't messed with it in the first place. Now that I've had a few days to mess around with SuSE, I don't like it at all... It's slow and complicated compared to Fedora.

Similar Threads

  1. Suse 10.1, Start program on boot
    By vwgtiturbo in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 05-17-2006, 06:11 PM
  2. How would I remove SuSE Linux from a Dual Boot Xp
    By cheetahman in forum Linux - General Topics
    Replies: 3
    Last Post: 07-02-2005, 06:50 PM
  3. Virus boot trouble
    By herman in forum Windows - General Topics
    Replies: 3
    Last Post: 05-31-2005, 06:44 PM
  4. XP/FC3 dual boot trouble
    By loren in forum Windows - General Topics
    Replies: 7
    Last Post: 02-11-2005, 12:53 PM
  5. Alternative boot method for Linux/Win2k dual boot
    By Spot in forum Windows - General Topics
    Replies: 8
    Last Post: 10-04-2002, 06:42 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts