I'm wanting to install gIFT onto my rh 8.0 system... but it says I need Pango 1.3.2 ... so i obtain it and proceed to installing it when i get this error

checking for GLIB - version >= 2.1.3...
*** 'pkg-config --modversion glib-2.0' returned 2.3.2, but GLIB (2.0.6)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** Glib 2.1.3 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org

I have glib 2.3.2 installed but i keep getting the same error msg.... Could someone plz direct me in the right direct