Results 1 to 3 of 3

Thread: proftpd & booting

  1. #1

    proftpd & booting

    I got my proftpd running. All works fine. I have to remove the file /var/lock/subsys/proftpd . Then I have to stop xinetd and then restart proftpd. (and I start xinetd again) Then it works. I tried booting protpd before xinetd but that does'nt work. What am I doing wrong? How can I boot without a manual start of proftpd? Need more info? Let me know

    Thanx in advance.


  2. #2

    Re:proftpd & booting

    I think you may have misunderstood the options open to you in starting proftpd. One option is to let xinetd handle starting and stopping proftpd for you. In this case, you never need to start or stop the actual proftpd service, you just need to restart the xinetd service.

    The second option is to start proftpd without the help of xinetd. In this case you simply need to execute the pfoftpd daemon from the CLI, create a run-level script to handle its booting, or add the path ot the prfotpd executable to to your rc.local script (I do it this way, since it is the simpliest). If you want to kill the server, simply do a 'pgrep pfroftd' to get its PID, then 'kill' that PID.

    If you want to run proftpd through xinted, refer to the docs at, they will explain everything.

    But, if I understand correctly in your asking 'I tried booting protpd before xinetd but that does'nt work,' then it seems that you are simply misunderstanding the options open to you in starting proftpd, namely that you 1) either start proftpd as its own deamon or 2) let xinetd handle the deamon for you. Option 2 is more secure, but you should not be trying to do both.

    I hope this helps and that I understood your question correctly.

    In my installation, I did away with using xinetd for proftpd and simply added this line to my rc.local script
    This starts proftpd automatically everytime my box boots.

  3. #3

    Re:proftpd & booting

    Thank you kind. Yes indeed I guess I had a few things mixed up pretty bad. Knowing this, a lot of problems and strange messages make a whole lot more sense. I'll start with removing proftpd form my boot cue. Then I'll look in to the rc.local.

    I'll let you know of any progress!

    Thanx again.

Similar Threads

  1. proftpd help
    By usaf in forum Redhat / Fedora
    Replies: 5
    Last Post: 04-19-2008, 01:05 PM
  2. New PET ::: ProFTPd on Ubuntu
    By Compunuts in forum Linux - General Topics
    Replies: 0
    Last Post: 03-11-2006, 07:09 AM
  3. Problem with Proftpd from WAN
    By Coral_Sea in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 06-13-2005, 07:28 PM
  4. proftpd
    By pinehead in forum Linux - General Topics
    Replies: 5
    Last Post: 07-27-2004, 06:41 PM
  5. proftpd
    By Kaiser_Sose in forum Linux - Hardware, Networking & Security
    Replies: 28
    Last Post: 01-22-2002, 01:57 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts