Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
mysql access error
Results 1 to 3 of 3

Thread: mysql access error

  1. #1

    mysql access error

    I'm trying to access mysql.
    I'm using the terminal and typed in "mysql"

    I then get the error:

    ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    What does this mean and how can I fix this?

    (I tried to use Tora as well, but got the same error)

  2. #2
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re:mysql access error

    is mysql running???

    try ps -ax | grep mysql

    who are you doing it as, root or a regular user?




  3. #3

    Re:mysql access error

    Remember that the mysql program is just the client. If the server isn't running, just run:

    safe_mysqld &

    Of course if you are wanting to connect to a different host. Just use the -h switch.

    mysql -h 192.168.0.1

Similar Threads

  1. Problem starting mysql conflicts with the RPM "mysql-5.0.27-1.fc6"
    By kamakshiganesh in forum Redhat / Fedora
    Replies: 2
    Last Post: 10-26-2007, 04:35 AM
  2. Yum error while installing mysql
    By omidkamangar in forum Redhat / Fedora
    Replies: 2
    Last Post: 09-14-2007, 10:54 AM
  3. MySql Error
    By paleogryph in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 01-23-2006, 07:53 AM
  4. MySQL database creation error
    By Compunuts in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 10-24-2003, 06:09 AM
  5. MySQL Error msgs
    By gmoreno in forum Announcements and Suggestions
    Replies: 4
    Last Post: 01-31-2003, 10:01 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •